Page 1 of 1

Symbols don't show correctly on orrery

Posted: Tue Aug 28, 2007 10:58 am
by ioannis
which font orrery uses for displaying the planets symbols?
thanks ioannis

Posted: Tue Aug 28, 2007 11:39 am
by gandreas
Apple Symbol.

There is a known issue with it sometimes not working that I've been trying to investigate.

symbols don't show correctly on orrery

Posted: Tue Aug 28, 2007 7:14 pm
by ioannis
are you sure you are using symbol font because i opened it with a font editor
and there are no planet symbols in that font.

Posted: Tue Aug 28, 2007 9:53 pm
by gandreas
Yes - use the "Character Palette" (either in your input menu, or Edit > Special Characters) and if you set view to "All Characters" and "By Category", under the Symbols category is "Miscellaneous Symbols". Selecting that, and about the fourth row down (depending on how wide your palette window is) are the signs (unicode 0x263F - 0x2647). Clicking on one of them and, if the "font variations" section is expanded, you'll see that they exist in the Apple Symbols font (a few of them are also found in some of the asian fonts as well, if you have those installed).

symbols don't show correctly on orrery

Posted: Wed Aug 29, 2007 4:41 am
by ioannis
I think we have found the problem
for some reason these characters do not appear on my computer
and surely the do not exist in the symbol font
I opened it and checked thoroughly with fontographer
maybe it would be safer to use a dedicated font for orrery so
it would not depend on the fonts of the system.