Page 1 of 1

AppleScript Error

Posted: Wed Feb 07, 2007 8:09 pm
by Sheba
I tried to run the "Make Julian Badge" script and I got this error message:

There was an error running the script 'Make Julian Badge': quadrium | flame got an error: "Prep Blank Document" doesn't understand the xABevent Qui ExecxBB message. ("Prep Blank Document" doesn't understand the xABevent Qui ExecxBB message.)

Is this another bug?

Posted: Fri Feb 09, 2007 2:48 pm
by gandreas
This is a known limitation of AppleScript support on pre-10.4 machines. Basically, there are two ways to add AppleScript support - the easier way that works for 10.4 and later (and, with a number of extra steps, more or less on 10.3), and the significantly more complex way that works with 10.3 but has potential issues on 10.4. You can guess which technique I picked...

I'll see if I can work some more of the extra steps from the former approach to add better support for 10.3.9, but with Leopard coming out soonish, my efforts will probably be more focused on compatibility with that.