Page 1 of 1

Odd treatment of formulae in 3.1.1

Posted: Sat Jan 12, 2013 5:34 am
by Sunspark
Hi, I'm a longtime user of the app & I love it - thank you for writing it. :D

OK, fanboi squee out the way, down to business.

I have recently updated my iPad 1 (early adopter!) to iOS 5.1.1, and Dicenomicon to 3.1.1 - The formulae in this thread:
viewtopic.php?f=27&t=524&p=3328&hilit=shadowrun#p3328

which I had been using just fine in Dicenomicon 3.0, seem to be rolling rather oddly - always coming up "1 with a glitch", and highlighting ones, not 5's and 6's.

so I went and had a look at them in the web editor, they look fine, but when saving, the editor 'validates' the first formula (basic roll no edge) to:

@2 <- #1d6=1. @1 <- $1>0 = 5. if @1 > 0 then 0 = @2 else 0 end

I'm pretty sure this is two different bugs, but if there were linguistic changes, maybe the internal parser isn't reading the old scripts ok?

Any pointers on where I might be going wrong?

Re: Odd treatment of formulae in 3.1.1

Posted: Wed Jan 16, 2013 8:10 pm
by Tektat04
Try this as code.

Code: Select all

@3 ← #1 d6 @ . 
@2 ← count1( @3 ) . 
@1 ← length( gt4( @3 ) ) . 
if @2 ≥ ( #1 / 2 ) then 
if @1 = 0 then 
“Critical Glitch!!” 
else 
@1 + “, But with a Glitch.” 
end 
else 
@1 
end
It won't do any of the highlight but does the count correctly.

Re: Odd treatment of formulae in 3.1.1

Posted: Thu Jan 17, 2013 4:32 am
by Sunspark
Thanks for the code update.

As part of debugging the previous scripts, I walked through adding one piece at a time to see what broke. Until I got to the end, and nothing had broken. The new typing of the old code worked fine.

So I tried the old formulae rolls - they worked.

Truly this is the work of madness. :tentacle: