Page 1 of 1

Various bugs

Posted: Sun Dec 06, 2009 9:20 pm
by mcc
Okay, nethack/iphone has made me incredibly happy. I do have a few bugs to report.

1. As I mentioned in the other thread, every time I launch nethack iPhone it says that I crashed on my previous run and it asks if I want to recover the crash. It did this the first time I ran. I have yet to actually crash.

2. If I go ahead and say "OK" to the crash recovery option, there is a typo. A dialog pops up that says "Unabler [sic] to recover crash file".

3. The "What is..." and "Name" features are not usable. When I try to use these features, I am prompted to select a square on the screen by using this nifty little magnifying glass that enlarges out one single character. The problem however is that I am only able to move this magnifying glass by placing my finger on it and dragging. Once I put my finger down however it is impossible to see the magnifying cursor, and so nearly impossible to select any specific space. It seems like this is the kind of feature that probably worked well in the simulator but doesn't work so well on the phone itself. What I would suggest doing is either having the magnifying glass "float" about a centimeter above the touch point like the cursor in Apple's text fields does; or making it so that dragging on the screen moves the magnifying glass by a corresponding amount rather than just forcing it to jump under your finger, so that you can say put your finger down an inch or so away and be manipulating it from there.

4. "What is..." seems glitchy in general. When I select a tile with "what is" I get a blank status line up top and a "More" box at the bottom, followed by a "More info?" dialog; if I ask for "More Info" I am given some sort of an encyclopedia entry on the object being looked at. It never actually tells me the object's name.

Also two observations that don't really qualify as "bug reports" but are problems I have been having:

- The "auto pick up" feature, as in your Rogue port, is really useful, but problematic because nethack compared to rogue has many more items which are strewn around but you don't want to pick up, for example because they are very heavy but offer limited benefit to carrying (such as chests, rocks, many corpses, those statues, etc). I also hear tell of a particular cursed object in nethack where you can trigger the curse just by picking it up. It would be really useful to have a selective auto-pick-up feature, say one which only picked up "not heavy" objects, or which allowed you to choose certain categories (potions, scrolls, gold) and say "only auto-pick up these".
- When I move in NetHack, as in Rogue, I normally do it using the double-tap "run". However similar to "auto pick up" there is a problem here that is not present in Rogue, because NetHack prints "incidental" messages ("you hear someone counting gold" etc) much more frequently. Often when I do a "double tap" I wind up accidentally clearing one of these messages which appeared on the first tap, then was cleared by the second tap before I had time to react. I think it would improve things if there were some mechanism in place to keep one from accidentally missing a message because one is running, though I am not sure what the best way to do this is (specially detecting the run and not clearing the message bar on the second tap? having a message block input for a brief amount of time, such that the run attempt will be ignored?).

Anyway great work on the port, looking forward to what it grows into :D

Re: Various bugs

Posted: Sun Dec 20, 2009 12:11 am
by mcc
And after playing some more, a couple more little observations if it isn't a bother:

- The "graphic characters" mode uses a single icon thingy for doors which are open, doors which are shut, and doorways which do not have a door at all. (In normal character mode different characters are used for each, in the full graphical mode there are different icons for each.) This makes it a bit more difficult to play in graphic characters mode because you can only test doors by bumping into them.

- For me at least whenever I select the "cast spell" or "spells I know" commands, there is a very long pause before the spell list appears and another very long pause after I select a spell before it acknowledges my tap. This seems to make it almost impossible to play as a wizard.