Symbols don't show correctly on orrery

Discuss the various current and future Widgets from gandreas software
Post Reply
ioannis
Posts: 3
Joined: Tue Aug 28, 2007 10:54 am

Symbols don't show correctly on orrery

Post by ioannis » Tue Aug 28, 2007 10:58 am

which font orrery uses for displaying the planets symbols?
thanks ioannis

gandreas
Immortal
Posts: 1464
Joined: Wed Feb 04, 2004 6:02 pm
Contact:

Post by gandreas » Tue Aug 28, 2007 11:39 am

Apple Symbol.

There is a known issue with it sometimes not working that I've been trying to investigate.

ioannis
Posts: 3
Joined: Tue Aug 28, 2007 10:54 am

symbols don't show correctly on orrery

Post by ioannis » Tue Aug 28, 2007 7:14 pm

are you sure you are using symbol font because i opened it with a font editor
and there are no planet symbols in that font.

gandreas
Immortal
Posts: 1464
Joined: Wed Feb 04, 2004 6:02 pm
Contact:

Post by gandreas » Tue Aug 28, 2007 9:53 pm

Yes - use the "Character Palette" (either in your input menu, or Edit > Special Characters) and if you set view to "All Characters" and "By Category", under the Symbols category is "Miscellaneous Symbols". Selecting that, and about the fourth row down (depending on how wide your palette window is) are the signs (unicode 0x263F - 0x2647). Clicking on one of them and, if the "font variations" section is expanded, you'll see that they exist in the Apple Symbols font (a few of them are also found in some of the asian fonts as well, if you have those installed).

ioannis
Posts: 3
Joined: Tue Aug 28, 2007 10:54 am

symbols don't show correctly on orrery

Post by ioannis » Wed Aug 29, 2007 4:41 am

I think we have found the problem
for some reason these characters do not appear on my computer
and surely the do not exist in the symbol font
I opened it and checked thoroughly with fontographer
maybe it would be safer to use a dedicated font for orrery so
it would not depend on the fonts of the system.

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests